User Guide

Plug-In for Outlook 98

GroupWise. 3.5




Legal Notices

Novell, Inc. makes no representations or warranties with respect to the contents or use of this documentation, and
specifically disclaims any express or implied warranties of merchantability or fitness for any particular purpose.
Further, Novell, Inc. reserves the right to revise this publication and to make changes to its content, at any time,
without obligation to notify any person or entity of such revisions or changes.

Further, Novell, Inc. makes no representations or warrantieswith respect to any software, and specifically disclaims
any express or implied warranties of merchantability or fitness for any particular purpose. Further, Novell, Inc.
reserves the right to make changes to any and al parts of Novell software, at any time, without any obligation to
notify any person or entity of such changes.

This product may require export authorization from the U.S. Department of Commerce prior to exporting from the
U.S. or Canada.

Copyright © 1993-1999 Novell, Inc. All rights reserved. No part of this publication may be reproduced,
photocopied, stored on a retrieval system, or transmitted without the express written consent of the publisher

U.S. Patent Nos 4,555,775; 4,580,218; 5,412,772, 5,701,459, 5,717,912; 5,760,772; 5,870,739; 5,873,079,
5,884,304; 5,903,755; 5,913,209; 5,924,096; 5,946,467; D393,457 and U.S. Patents Pending.

Novell, Inc.

122 East 1700 South
Provo, UT 84606
U.S.A.

www.novell.com

GroupWise 5.5 Plug-In for Outlook 98 Overview and Installation
August 1999
104-001165-001

Online Documentation: To access the online documentation for this and other Novell products, and to get
updates, see www.novell.com/documentation.



Novell Trademarks

Novell is aregistered trademark of Novell, Inc., in the United States and other countries.

NetWare is aregistered trademark of Novell, Inc., in the United States and other countries.

GroupWise is aregistered trademark of Novell, Inc. in the United States and other countries.

NDS is atrademark of Novell, Inc.

Novell Support Connection is a registered trademark of Novell, Inc. in the United States and other countries.
ZENworksis atrademark of Novell, Inc.

Third-Party Trademarks

Microsoft is aregistered trademark of Microsoft Corporation.
Outlook is atrademark of Microsoft Corporation.

Pentium is aregistered trademark of Intel Corporation.
VirusScan is aregistered trademark of Network Associates, Inc.
Windows is aregistered trademark of Microsoft Corporation.
Windows NT is aregistered trademark of Microsoft Corporation.






Contents

GroupWise 5.5 Plug-In for Outlook 98 Overview

1 Understanding

What Isthe Plug-In? . . . . . . . . . . . . e 9
How Does the Plug-InWork? . . . . . . . . . . . . . .. .. ... . .. ..... 9
Windows Messaging Profiles and Information Services. . . . . . . ... .. 10
Frequently Asked Questions (FAQ). . . . . . . . . . . . . . 10
2 Setting Up
Minimum System Requirements . . . . . . . . . . ..o 11
Installing the Plug-In . . . . . . . . . . . .. 12
Procedure . . . . . . . L 12
Installed Files . . . . . . . . . . e 13
Uninstallingthe Plug-In . . . . . . . . . . . . . 13
3 Migrating Existing Messages and Address Book Information into the

Plug-In

4 Features in the Plug-In

5 Using the Plug-In
Using GroupWise Startup Options . . . . . . . . . . . . o 21
GroupWise Startup Options . . . . . . . . . . .. 22
Using Multiple Profiles . . . . . . . . . .. . 23
6 Troubleshooting
Known Issues . . . . . . . . . 25
Error Messages . . . . . . . . . e e e e 27
Determining the Version ofthe Plug-In . . . . . . . . . .. ... ... ...... 29

Contents 5



6  GroupWise 5.5. Plug-In for Outlook 98



GroupWise 5.5 Plug-In for Outlook 98 Overview

The GroupWise® 5.5 Plug-In for Outlook* 98 provides GroupWise e-mail,
calendaring, scheduling, and collaboration functions from within the Outl ook
98 client.

By making use of this plug-in, users can choose to use GroupWise or Outlook,

or both. Outlook users can keep their existing data and don’t have to lea
new product when the company moves to GroupWise. Likewise, GroupV
users can keep their existing data and don’t have to learn a new product
example, if the company integrates with a group of Outlook users or if pal
the company prefers Outlook.

The network administrator's job of managing a Microsoft* desktop systen
a mixed NovelP and Microsoft desktop systemissimplified by the reliability,
scalability, and manageahility of the GroupWise message store and message
transport. Administrators also have the choice of managing the entire
collaboration environment with the stability, scalability, and lower cost of
ownership of NetWare® and NDS™.
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Understanding

Choose from the following list of topicsto learn more about the GroupWise®
5.5 Plug-in for Outlook* 98:

O “What Is the Plug-In?” on page 9
O “How Does the Plug-In Work?” on page 9

O “Frequently Asked Questions (FAQ)” on page 10

What Is the Plug-In?

The GroupWise 5.5 Plug-In for Outlook 98 is your solution for accessing
GroupWise mailboxes from within Outlook. You can also access your
mailbox from within GroupWise.

How Does the Plug-In Work?

The GroupWise 5.5 Plug-In for Outlook 98 uses MAPI to communicate to
the necessary GroupWise information services from within Outlook. MAP
a specification that describes the communication between a messaging

application (for example, GroupWise) and information services (also call
service providers), defines the information services, and functions as the
actual communication between the messaging application and the inform:
services. Each information service performs a function, such as storing it
or receiving items.
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Windows Messaging Profiles and Information Services
A Windows* Messaging (MAPI) profile contains information that is used by
amessaging application, such as GroupWise or Outlook, to send and receive
items, store itemsin folders, and obtain user address books. You can have
multiple profiles.
A profile contains alist of information services. Information servicesinclude

your message store, address books, or personal folders, and tell the messaging
application where to find these components.

Frequently Asked Questions (FAQ)

To read the most current FAQ, see TID 2952715.
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Setting Up

Choose from the following list of topics:

O “Minimum System Requirements” on page 11

O “Installing the Plug-In” on page 12

O “Uninstalling the Plug-In” on page 13

Minimum System Requirements

The minimum system requirements are as follows:

*

GroupWis& 5.5 system with GroupWise 5.5.2 agents, including
GroupWise Internet Agent 5.5.2.

Internet Addressing must be enabled.

Outlook* 98 Corporate or Workgroup (CW) installation. The Internet
Mail Only (IMO) and the No E-mail installation options are not
supported. Outlook Expressis not supported. Use of the Plug-1n with
Outlook 2000 is not supported.

PC with a Pentium* 75 MHz or higher processor.

Microsoft* Windows* 95 or later operating system, or Microsoft
Windows NT* Workstation operating system version 4.0 Service Pack 3

or later.

For Windows 95 or Windows 98: 32 MB of RAM.
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+ For Windows NT Workstation: 48 MB of RAM.
¢ 7 MB of available hard-disk space.
The GroupWise 32-bit client is not required in order to use the GroupWise

Plug-1n for Outlook 98.

Installing the Plug-In

Choose from the following list of topics:
O “Procedure” on page 12

O “Installed Files” on page 13

Procedure
To download and install the GroupWise 5.5 Plug-In for Outlook 98,

1 Go to the Novell Support Connectf®Minimum Patch List at:
http://support.novell.com/misc/patl st.htm

2 Download the GroupWise 5.5 Support Pack 2 and install the 5.5.2 agents,
including GroupWise Internet Agent 5.5.2, on your GroupWise system.

3 Gotothe Novell Software Downloads site at:

http://www.novell.com/downl oad/#GroupWise

4 Click GroupWise 5.5 Plug-In for Outlook 98 and save the file to a new
folder. Run GWPLUGL.EXE to expand all the filesinto the folder.

5 Make sure you exit Outlook and GroupWise before installing the
GroupWise Plug-1n.

6 Run SETUPEXE from the folder to install the GroupWise Plug-1n.

You can also distribute the Plug-1n using ZENworks™.
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Installed Files

The Plug-In setup program installs the following files to the Windows System
directory:

gwabp132.dll
gwabplus.dll
gwabs132.dl
gwabslus.dll
gwecmal.dll
gwcmalus.dll
gwecma2.dll
gwcma2us.dll
gwenvl.dll
gwmsp132.dil
gwmsplus.dll
imagehlp.dil

Uninstalling the Plug-In

If you have both Outlook and GroupWiseinstalled on your workstation, do not
uninstall the Plug-1n or some GroupWise files may be removed. Just change
the profile you are using in Outlook by clicking Tools > Options > the Mail
Services tab > selecting a different default profile.

If you have only GroupWiseinstalled on your workstation, you do not need to
uninstall the Plug-In.

If you have only Outlook installed on your workstation,
1 Inthe Windows Control Panel, double-click Add/Remove Programs.
2 Click GroupWise 5.5 Plug-In for Outlook 98.

3 Click Remove > Yes.
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Migrating Existing Messages and
Address Book Information into the
Plug-In

When you install the Plug-1n, a new Windows* Messaging profile named
Novell Default Settings is created. The profile lists the information services
used by GroupWi se®: Novell GroupWise Message Store, Novell GroupWise
Address Book, and Novell Personal Address Book. When you start Outlook*,
this profile will access your GroupWise mailbox. You may already have
Outlook information services in existing profiles, such as Personal Folders,
Outlook Address Book, or Microsoft Exchange Server. You may also have
information servicesin existing POP or IMAP account profiles. To see these
items when you use Outlook with the Plug-1n, you need to add these
information services to the Novell Default Settings profile.

To do this,

1 In the Windows Control Panel, double-click Mail.
or

In Outlook, click Tools > Services.

2 Makesurethedialog box isthe Novell Default Settings Properties. If itis
not, click Show Profiles > select Novell Settingsin the drop-down list >
click Close.

3 Click Add.
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4 Select the information services you want to add > follow the prompts.

If you added a message store information service, you will see a new
hierarchy of foldersin your Folder List. If you added an address book
information service, you will have an additional address book on the
Show Names From The drop-down list in the Address Book.

To make sure all new items go into the Novell GroupWise Message Store and
Novell GroupWise Address Book,

1 Start Outlook.

2 |If you added a Message Store information service, use drag and drop to
move the messages from your added hierarchy of foldersinto your Novell
GroupWise Message Store folders.

3 If you added an Address Book information service, go to the Address
Book > Shift+Click all entriesin the added address book > click File >
Add to Personal Address Book.

Theentrieswill be added to the addressbook specifiedin Tools > Options
> Keep Personal Addresses In.

4 Onceyou have moved all messages and/or address book entries out of the
added information service, double-click Mail in the Windows Control
Panel.

5 Select theinformation service you just completed moving all information
out of > click Remove > Yes.
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Features in the Plug-In

Because Outlook* and GroupWi se® arenotidentical products, itisimpossible
for all the features to match up after installing the Plug-In. Therefore, some
features may work differently or may not work at all.

*

E-mail: Full e-mail capabilities are supported.

Personal Scheduling: Full personal appointments and tasks are
supported.

Group Scheduling: Group scheduling is partially supported. Task
information such as Due Date and Status appearsin two places. abovethe
Message field and in the Message field. The valid information isin the
Message field.

Receiving an Appointment: Recipients of an appointment receive the
appointment and can accept it.

Receiving a Task in Outlook from an Outlook Sender: Recipients of
atask receive anorma mail message in their Mailboxes.

Receiving a Task in Outlook from a GroupWise Sender: Recipients
of atask receive atask in their Mailboxes. When the recipient opens the
task, it is automatically accepted and placed in the task list.

Receivinga Task in GroupWisefrom an Outlook Sender: GroupWise
recipients of atask receive anormal mail message with an embedded task.

Recurring Appointments (Auto-Date): Recurring (auto-date)
appointments are not supported.
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+ Notes: Notesin Outlook and GroupWiseare slightly different from each
other. With the Plug-1nin Outlook, notesfunction asthey normally would
in Outlook.

The message text of anote displaysin the subject line of the note, and the
subject text of the note does not display.

* Free/Busy: Free/Busy search isnot supported.

+ Journaling: Journaling is not supported. The Journal folder displaysin
the folder list, but Journaling should not be turned on.

+ Contacts. Contacts are supported, with the exception of the Birthday
and Anniversary fields.

¢ Sent Items. Without the Plug-In, Outlook places created itemsin the
Out Box folder, and then moves them to the Sent Items folder once they
are sent. With the Plug-In, al sentitemsin Outlook are placed in the Sent
Items folder and the Out Box folder remains empty.

+ Distribution Lists (Groups): You can send itemsto distribution lists
(groups) that are created in GroupWise, but you cannot create or edit
distribution lists in Outlook.

+ Rules: Rulesthat are created in GroupWise are supported. Rulesthat are
created in Outlook are not supported.

¢ Find: Advanced find is not supported. Simple find (Tools > Find) is
supported and is very fast.

+ Folders. InGroupWise, folderscan bearranged in the order you choose,
but in Outlook they are arranged al phabetically. In Outlook with the Plug-
In, they will display alphabetically. You can create personal foldersto add
to your folder list.

Drafts and Work in Progress folders will both show draft messages,
depending on whether you were using Outlook (Drafts) or GroupWise
(Work in Progress) when you saved the draft.

Shared folders and query folders are not supported.

After Outlook and the Plug-In are installed, GroupWise will show three
new folders: Drafts, Journal, and Notes. These should not be del eted.
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GroupWise Password: Outlook does not provide away to set a
password. If you would like a password for your GroupWise mailbox,
you must set it in GroupWise.

Remote: Remoteis not supported in Outlook with the Plug-In. Install
and use GroupWise Remote.

Delegates (Proxy): Delegatesis not supported.

Archiving: Archiving as afeatureis not supported. However, you can
store items on your local driveif you add a Personal Foldersinformation
service to your Novell Default Settings profile. Double-click Mail in the
Windows* Control Panel > click Show Profiles > select Novell Default
Settings > click Add > follow the prompts to add the Personal Folders
information service.

Document Management: GroupWise document management is not
available in Outlook.
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Using the Plug-In

When you start Outlook* , you may see a GroupWise® login dialog box. Enter
your user ID, password, and mailbox |ocation. Outlook will open and show all
of your GroupWise folders and items.

Click atopic to learn about other options for using the Plug-In:

O “Using GroupWise Startup Options” on page 21

O “Using Multiple Profiles” on page 23

Using GroupWise Startup Options

To use a startup option,

1 Double-click Mail in the Windows* Control Panel.
or

In Outlook, click Tools > Services.
2 Select Novell GroupWise Message Store > click Properties.
3 Type one or more startup options in the GroupWise Command Line fi
4 Click OK.

Each time you start Outlook, the startup options will be used.
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GroupWise Startup Options
You can specify the following GroupWise startup options:

* /@u-?

Displaysthe GroupWiselogin dialog box whenever you open Outlook, so
you can supply any necessary login information. This startup option
allows multiple users to be prompted for login information if they share
the same workstation for e-mail.

¢ /@u-USER ID

L ets you use your GroupWise user 1D to open Outlook as yourself on
another user’s computer. The other user remains logged on to the
network.

¢ /ipa-IP ADDRESS
Lets you specify the IP address.

¢ [ipp-IP PORT
Lets you specify the IP port.

¢ /la-NETWORK ID

Lets you specify your network ID to open Outlook as yourself on anothe
user’'s computer. The other user remains logged on to the network.

¢ /ph-PATH TO POST OFFICE

Lets you specify the path to your post office.
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Using Multiple Profiles

You can create multiple MAPI profiles on the same workstation, each with its
own list of information services. For example, you might have Ranjo’s Prof
Claudia’s Profile, and Louie’s Profile if all three share the same workstati
for e-mail.
To create a profile based on the Novell Default Settings profile,

1 Double-click Mail in the Windows Control Panel.

2 Click Show Profiles.

3 Click Novell Default Settings > Copy.

4 Type a name for the profile > click OK.

5 In the drop-down list, specify the profile you want to use when startir
Outlook.

6 Click Close.
You can also click Tools > Options > the Mail Services tab in Outlook to

specify a default profile or to specify to be prompted to enter a profile ea
time you start Outlook.
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Troubleshooting

Choose from the following list of topics:

O “Known Issues” on page 25

Q “Error Messages” on page 27

U “Determining the Version of the Plug-In” on page 29

Known Issues

Issue: My Mailbox doesn’t show new messages as they arrive. Wher
mark a task Complete, it doesn’t appear to be marked Complete.

Explanation: Outlook* does not refresh your view automatically. You
need to exit and restart Outlook to see these items.

Issue: When | try to install the Plug-In, | get an error that
GWMSP132.DLL failed to register.

Explanation: GroupWis& was running in the background. Close
GroupWise and GroupWise Notify, then run the Plug-In SETUREXE
again. If this doesn't solve the problem, reboot the machine to be sure the
GroupWise and the MAPI spooler are not |oaded. Re-run the Plug-In
SETUPEXE.

Issue: When | start Outlook 98 after installing the Plug-In, | get an error

that Outlook 98 cannot start because MAPI32.DLL is corrupt or the
wrong version.
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Explanation: Rename the MAPI32.DLL filein your Windows* system
directory and reinstall Outlook 98. You do not need to re-run the Plug-In
SETUPRPEXE.

+ |ssue: When | exit Outlook 98 it crashesin EMALSCAN.DLL.

Explanation: This problem occurs on machines with McAfee
VirusScan* installed and the Exchange scan add-in enabled in Outlook
98. A patch isavailable from Network Associates or you can disable the
add-in in Outlook 98. See Microsoft's knowledgebase (Article ID:
Q198063) for more information.

+ |ssue: When | accept an appointment, it staysin my Mailbox folder.

Explanation: Accepted appointments take along time to "disappear”
from the Mailbox folder. You can exit and restart Outlook 98 if you need
to get rid of them. They will display correctly in your calendar, even if
they haven't yet disappeared from the Mailbox folder.

+ Issue: When | accept an appointment, | get a message, "You cannot
respond to a message without an organizer. You must add an organize
field to the item." | click OK and the appointment is accepted.

Explanation: Choose "Don't Send a Response" when prompted after
clicking Accept. No message will appear.

+ Issue: | perform an advanced find and never get any results back.

Explanation: Advanced find is not supported. Simple find (Tools > Find)
is supported and is very fast.

+ Issuel | send a recurring appointment but only the first occurrence is
received.

Explanation: Recurring appointments or auto-dates are not supported ir
this release. The data for the recurring appointment displays in the
message body or header of the appointment.

+ |ssue: | can't create or modify a distribution list. When | try to create a
distribution list, | get a message, "A new entry could not be added."

Explanation: This is not supported. You can send to distribution lists
(groups) that are created with the GroupWise client.
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+ Issue: When | change the color settings in Outlook 98, | get a General
Protection Fault error in module OUTLIB.DLL or OUTLOOK.EXE.

Explanation: Thisisaknown problem without a known workaround.
The color settings cannot be changed.

* Issue: When | receive a hote, the message text displays in the subject
line, and the subject text of the note does not display.

Explanation: Thisisaknown problem without a known workaround.

+ |ssue: | get an Opened notification when recipients open amessage | sent
to them. My tracking options are turned off.

Explanation: Currently, you cannot turn this off in the Outlook 98 client.
The Plug-In will always generate the opened notification.

¢ |ssue: | am alwaysincluded in the To: line when | reply to all.

Explanation: You need to manually remove your name if you do not
want to receive your reply.

¢ |ssue: | cannot view HTML messages.

Explanation: HTML messages will not display astext in the Message
field, but will be attached to the message. Double-click the attachment to
launch your browser and read the message.

To see the most current list of Known Issues, see TID 2952715.

Error Messages

In the event of an error in GroupWise, a GroupWise error message is
generated that is taken by MAPI to Outlook. Because MAPI has a much
smaller set of error messages, some messages may hot match the original
GroupWise error message. The MAPI messages that may be matched with the
original GroupWise error messages include the following:
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MAPI Error Message

Description

MAPI_E_NOT_ENOUGH_MEMORY

MAPI_E_INVALID_PARAMETER

MAPI_E_UNKNOWN_FLAGS

MAPI_E_CALL_FAILED

MAPI_E_NO_ACCESS

MAPI_E_NO_SUPPORT

MAPI_E_NOT_FOUND

MAPI_E_LOGON_FAILED

MAPI_E_TOO_COMPLEX

Any time a memory function call fails in the GroupWise engine or the
Novell® GroupWise Message Store information service, this is the
error. This includes bad (corrupt) memory as well as out of memory
situations.

When a bad parameter is received from Outlook in the Message
Store information service, this is the error. For example, Outlook
could pass the Novell GroupWise Message Store information
service a bad pointer or bad address.

Many of the functions that Outlook calls in the Novell GroupWise
Message Store information service have flags as parameters. This
error is returned if the flags passed by Outlook are not recognized.

This is a generic error message, with many possible causes. Most of
the GroupWise engine errors are mapped into this error.

This error is returned to Outlook from the Message Store information
service when the current user does not have permission to perform
the current action.

This error is returned to Outlook from the Message Store information
service when a user tries to perform an action or use a feature that
GroupWise doesn't support.

This error is returned to Outlook from the Message Store information
service when Outlook attempts to locate a folder or message and it
is not found.

This error is returned during login to the Novell GroupWise Message
Store information service if the login information given did not
authenticate properly.

This error is returned to Outlook from the Novell GroupWise
Message Store information service when Outlook has requested
filter or selection criteria that are too complicated to handle.

You will not see the MAPI error messages listed above, because they in turn
trigger an Outlook error message depending on the context of the error. The
error message displayed by Outlook will be similar to but may not exactly
match the MAPI error message.
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Determining the Version of the Plug-In
To find out the version of the Plug-In you haveinstalled,
1 On the Windows desktop, click Start > Find > Files or Folders.

2 Type gwmspl32.dll > click Find Now.

3 When thefileisfound, right-click the filename > click Properties.

The date of thisfile indicates the version of the Plug-In.

Troubleshooting
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